社労士が顧問先へ、メールに添付して「顧客ファイル」や「入力表」、「顧客明細書」を送信し、顧問先のパソコンで起動すると、Excel画面上部に「セキュリティリスク:このファイルのソースが信頼できないため、Microsoftによりマクロの実行がブロックされました」と表示され、正常に起動できない事象を確認しています。
原因
本事象はMicrosoft Officeのアップデートにより、バージョン2203以降から順次セキュリティが強化されていることに起因します。これによりインターネットから入手したファイル内のマクロがブロックされる仕様に変更されました。
Microsoft Officeのアップデート内容の詳細については、以下リンク先をご参照ください。
【Microsoft関連情報:Office でインターネットから入手したマクロが既定でブロックされる】
対処方法
顧問先側のパソコンで以下の設定をおこなっていただき、再度「顧客ファイル」「入力表」「顧客明細書」を開き直すことで解消します。
- メールに添付されている「顧客ファイル」「入力表」「顧客明細書」をダウンロードし、デスクトップに貼り付けます。
- 1のファイルの上で右クリックをし、「プロパティ」をクリックします。
- 「全般」タブを開き、「許可する」のチェックを入れて「適用」をクリックします。
※「適用」をクリックすることで、セキュリティの警告表示が出なくなります。 - ファイルが正常に開くかを確認します。
なお、この操作は、ファイルごとにおこなう必要があります。